KDE Plasma Browser Integration on Debian

- Debian, KDE

Probably you are wondering what is the Plasma Integration Browser.

As you can see on the video is a cool extension that can deprecate the KDE Connect for browser very easily.

Sadly the module to install for the extension is not available on Debian…

If you see on Addons Store for Firefox, they say that the package is available on your distro, but this is not true.

There is a package request on Debian for that without any updates: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=890778

So what is the solution for us?

Download the latest build for KDE Neon that is Ubuntu based and not have issues on Debian Sid!

You can download it on http://archive.neon.kde.org/dev/unstable/pool/main/p/plasma-browser-integration/

Download plasma-browser-integration_0.0+p16.04+gitxxxx-0_amd64.deb package and install 🙂

Update: since 2018/07/13 there is a debian package in repository, just run apt install plasma-browser-integration and it’s done.

After install this, add the extension on your browser or restart and the integration is active!

Liked it? Take a second to support Mte90 on Patreon!

Become a Patreon
All the stuff released in this website, where the author is Daniele Scasciafratte, is under the GPL 2.0 license except when the resources have their licenses.

2 Responses to “KDE Plasma Browser Integration on Debian”

  1. Su buster quasi funziona, ma richiede librerie più aggiornate:

    Preparing to unpack plasma-browser-integration_5.13.0+p16.04+git20180617.0023-0_amd64.deb …
    Unpacking plasma-browser-integration (5.13.0+p16.04+git20180617.0023-0) …
    dpkg: dependency problems prevent configuration of plasma-browser-integration:
    plasma-browser-integration depends on libqt5core5a (>= 5.11.0+dfsg); however:
    Version of libqt5core5a:amd64 on system is 5.10.1+dfsg-7.
    plasma-browser-integration depends on libqt5dbus5 (>= 5.11.0+dfsg); however:
    Version of libqt5dbus5:amd64 on system is 5.10.1+dfsg-7.
    plasma-browser-integration depends on libqt5gui5 (>= 5.11.0+dfsg); however:
    Version of libqt5gui5:amd64 on system is 5.10.1+dfsg-7.
    plasma-browser-integration depends on libqt5widgets5 (>= 5.11.0+dfsg); however:
    Version of libqt5widgets5:amd64 on system is 5.10.1+dfsg-7.

    Non sono riuscito a trovare un pacchetto più vecchio, senza quelle dipendenze.

    • Già me ne sono accorto l’altro giorno che non si installa più su Debian Sid causa dipendenze ma a breve aggiornano KDE su debian. NOn so se vale la pena modificare il pacchetto manualmente.

Leave a Reply